Plesk / Horde – Horror-Bug – Mail-Anhänge gehen verloren !

Ein guter Kunde hat uns heute kontaktiert, weil alle seine Mail-Attachements verschwunden sind und so haben wir uns natürlich auf die Suche gemacht, dieses Problem zu analysieren!

Auf jedem Plesk 11.5.30/12.0 – Server in Verbindung mit Horde (OS Debian) gehen alle Anhänge, die über Horde eigentlich an den Empfänger gehen sollen, unter immer nachvollziehbaren Umständen verloren! Wir beschreiben hier genau, wie daß passiert! Plesk 11.5.30 und auch Plesk 12.0 stellt 2 verschiedene Online-Mail-Clients bereit, die ein Server-Administrator über Plesk installieren kann und seinen Kunden bereit stellen kann! Plesk legt dabei auch diverse Konfigurations-Dateien in diversen unterschiedlichen Verzeichnissen an und legt auch Log-Verzeichnisse etc. an.

Im ersten Moment sieht alles gut aus und Mails können über diesen Online-Client versendet und auch abgerufen werden. Standardmäßig und nicht in Plesk einstellbar ist, daß dabei Anhänge nicht mit der Mail versendet werden, sondern als Link in die Mail eingebettet werden! In der Mail erscheint dann zusätzlich ein Hinweis, daß der Link eine lange Gültigkeit von mehreren Monaten hat!

Dies ist schon mal eine sehr ungewöhnliche Vorgehensweise, die auch mehrfach schon an Parallels, den Hersteller von Plesk heran getragen wurde, aber bis zur Version 12.0 nicht abgestellt wurde, denn normal ist üblich, daß mit Mails auch die Attachements gesendet werden und nicht Links statt Attachements! Dies ist auf der Knowledge-Base von Plesk, hier nachlesbar und man mag es gar nicht glauben, es ist seit 27.09.2013 bekannt! 

Aber auch das Senden eines Links, um die Datei beim Empfänger dann abrufen zu können, ist nicht unbedingt schlimm, wenn man davon ausgehen kann, daß die dazugehörigen Dateien zum Abruf, auf dem Versand-Server auch so lange gespeichert bleiben, wie dies in der Mail mit dem Hinweis: „Anhänge: (Links laufen am 31.03.2015 ab) angegeben ist!

Aber jetzt informieren wir hier über den absoluten Plesk-Gau:

Die Attachement-Dateien, werden im Verzeichnis /tmp/.horde gespeichert! Aus diesem Verzeichnis werden die Dateien beim Anklicken des Links in der Mail, die der Empfänger erhalten hat, abgerufen!

Alle Attachements (angefügte Dateien), die über Horde als Link versendet wurden, gehen bei Plesk-Servern 11.5.30 / Plesk 12.0 unter Linux Debian, Ubuntu, Kubuntu etc. pp verloren, wenn der Server neu gestartet wird, weil der Ordner /tmp beim Neustart eines Servers, standardmäßig bei diesen OS-Distributionen gelöscht wird! Grundsätzlich ist der Ordner /tmp nur für temporäre Dateien gedacht und kein Speicherplatz, um dauerhaft hier Dateien zu speichern!  

Wir können also momentan nur jedem empfehlen, nicht über Horde Mails mit Attachements zu versenden! Wir haben momentan keine Lösung, um dieses Problem abzufangen, außer ggf. zu prüfen, ob der andere Mail-Client, der unter Plesk installierbar ist, besser geeignet ist! Daß mit Plesk jedoch ein schlecht konfigurierten Mail-Client bereit gestellt wird, der Daten vernichtet und bei dem auch standardmäßig alle Logs nicht funktionieren, ist eine absolute Unmöglichkeit!

Das könnte Sie auch interessieren:

BUG oder FEATURE: Mails to root@eineDomain werden an Admin weiter geleitet

TOP: Club-Domain – Promotion – jetzt Geld sparen

Massives Sicherheitsproblem in Plesk 11.5 entdeckt

Horror-Bug in Nginx (Plesk 12.0 / Webpresence Builder) gefunden

Jetzt auch bei den kleinen vServern: bis zu 4 IPv4 möglich

2 Gedanken zu „Plesk / Horde – Horror-Bug – Mail-Anhänge gehen verloren !“

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.